Frequency Foundry - Click Dimension - AWS Outage Causing Email Send and Statistics Delays – Incident details

All systems operational

Click Dimension - AWS Outage Causing Email Send and Statistics Delays

Resolved
Operational
Started over 3 years agoLasted 1 day

Affected

Partner Services

Operational from 5:37 PM to 5:59 PM

Click Dimensions Marketing Automation

Operational from 5:37 PM to 5:59 PM

Updates
  • Resolved
    Resolved

    From Click Dimensions,

    After investigation our teams have determined that some emails sent during the outage period have failed to send. The Amazon outage was first reported by Amazon at 9:37 AM PST on 12/7/2021 and was reported as resolved at 4:35 PM PST. During this time, some Email Sends sent by accounts in our US Data Center failed to send despite showing as "Sent" within D365/CRM.

    We have put together guidance on how to identify and re-process Email Sends that were unable to send due to the Amazon Web Services outage that impacted our US Data Center on 12/7/2021. It can be found here: https://support.clickdimensions.com/hc/en-us/articles/4415953657613

    We recommend customers review the linked guidance and determine if emails were impacted, and if the impacted email sends should be sent now.

  • Monitoring
    Monitoring

    AWS has listed the issue as resolved. We are monitoring for any potential lingering effects to our infrastructure.

  • Investigating
    Investigating

    We are aware of an outage in AWS that is causing delays on email sends and statistics reporting in the AU, CAN, and US data centers. Please follow updates on the AWS status page located here: https://status.aws.amazon.com/

    This incident affects: CAN Data Center (Email), US Data Center (Email, Email Statistics), and AU Data Center (Email).