Frequency Foundry - Frequency Foundry Support Ticket Notification Emails – Incident details
All systems operational
Frequency Foundry Support Ticket Notification Emails
Resolved
Major outage
Started about 1 month agoJune 02, 2026Lasted 1 day8:35 PMJune 04, 202612:19 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This is resolved, all ticket update emails are sending successfully.
Identified
UTC
Identified
UTC
We are aware that ticket update emails have not been sent out, we are working on a fix. Please for now, monitor your cases in the support portal to view any updates on your cases.