Frequency Foundry - Click Dimensions Intermittent Email Delays in US – Incident details

All systems operational

Click Dimensions Intermittent Email Delays in US

Resolved
Operational
Started almost 4 years agoLasted about 4 hours

Affected

Partner Services

Operational from 4:13 PM to 7:55 PM

Click Dimensions Marketing Automation

Operational from 4:13 PM to 7:55 PM

Updates
  • Resolved
    Resolved

    Internal testing and customer reports have indicated positive results from the implemented fix. If you continue to experience difficulties please open a Frequency Foundry support ticket.

  • Monitoring
    Monitoring

    The team has implemented a fix in the email server that was causing some emails to be delayed. We are monitoring the results of the fix and will provide further updates as soon as they are available.

  • Identified
    Identified

    The issue has been identified in our email server and a fix is being created.

  • Investigating
    Investigating

    They are investigating the issue where some US customers may encounter delays on their email sends.