Frequency Foundry - Click Dimensions Occasional Email Delays in US Data Center – Incident details

All systems operational

Click Dimensions Occasional Email Delays in US Data Center

Resolved
Operational
Started almost 4 years agoLasted 1 day

Affected

Partner Services

Operational from 3:27 PM to 3:46 PM

Click Dimensions Marketing Automation

Operational from 3:27 PM to 3:46 PM

Updates
  • Resolved
    Resolved

    After monitoring the issue overnight the team has concluded the fix to be viable. They will continue monitoring for any recurrence.

  • Monitoring
    Monitoring

    The team has implemented a fix in the email server and we are monitoring the results.

  • Identified
    Identified

    They have identified an issue causing some emails to be delayed in the US Data Center and are working on a fix.