Frequency Foundry - Intermedia - Some Customers Experiencing Connectivity Issues while utilizing Voice Services and placing/answering phone calls – Incident details

All systems operational

Intermedia - Some Customers Experiencing Connectivity Issues while utilizing Voice Services and placing/answering phone calls

Resolved
Operational
Started over 3 years agoLasted about 3 hours

Affected

Telax-Intermedia

Operational from 4:10 PM to 7:00 PM

Intermedia/Telax Hosted Contact Center Voice

Operational from 4:10 PM to 7:00 PM

Updates
  • Resolved
    Resolved

    Resolved - Voice Services functionality has been restored. All users are able to use Voice Services without issue. Currently, all support channels are operating as normal. Our Network Administrators identified the root cause as a DDoS attack that impacted Voice Services functionality across multiple data centers. We have now mitigated the issue. All services are now working as expected. Due to a high volume of requested call backs around this issue, a return call may be delayed or not completed. For any further questions, please call or chat.

  • Investigating
    Investigating

    http://status.mycontactcenter.net/

    Update - We are currently experiencing a network issue that is impacting some of our customers. Our DNS servers in all US data centers are receiving significantly more than normal traffic, which is impacting voice services for some customers. We are actively working to resolve the situation. We sincerely apologize for the inconvenience and will provide more information on the resolution shortly. Dec 17, 10:48 EST

    Update - We are continuing to investigate this issue. Dec 17, 10:03 EST

    Investigating - Our System Administrators have identified networking issues and are working with Network engineering to identify and resolve the issue. We'll provide another update as we make progress. Dec 17, 09:56 EST