Frequency Foundry - Intermedia Security - Required Enablement of Two-Factor Authentication for Administrator Portals – Incident details

All systems operational

Intermedia Security - Required Enablement of Two-Factor Authentication for Administrator Portals

Resolved
Operational
Started about 3 years agoLasted over 1 year

Affected

Telax-Intermedia

Operational from 7:32 PM to 3:39 PM

Intermedia/Telax Hosted Contact Center Voice

Operational from 7:32 PM to 3:39 PM

Intermedia/Telax Hosted Contact Center Email

Operational from 7:32 PM to 3:39 PM

Intermedia/Telax Non-Critical Services

Operational from 7:32 PM to 3:39 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Two-Factor Authentication (2FA) – one of the most well known and widely used methods of identity verification – is also one of the most effective, and for good reason – it works. Like many other platforms, Intermedia has made the decision to require 2FA for all administrators and users accessing Partner Portal and Control Panel, beginning later this month. Please note, there is no reason to wait for this requirement to go into effect – enable 2FA for administrators at any time.

    Navigate to the 2FA Information Page below to view the informational video, review detailed FAQs, and more. Topics covered include:

    What this means for you:

    • Why we are making this decision

    • How to enable 2FA for administrator portals

    • Everything you need to do after 2FA is enabled

    • Other tips for keeping your customers’ organizations secure

    • An overview of partner resources to help communicate these changes to your customers

    https://go.intermedia.com/2fa-kit/?mkttok=NTI0LVZUUy04MzIAAAGCXBhsztgfO-Nk4dKTF5a-GeMmEi4JeUKr3ElZsAPMftV38JmQqLXCCusLKb679D21AN620sKho4b6CFD42oquYW3tGcjnJgq1AzKhjb4TziJw