Frequency Foundry - ClickDimensions - Delays for participants in Campaign Automations in the US data center – Incident details

All systems operational

ClickDimensions - Delays for participants in Campaign Automations in the US data center

Resolved
Operational
Started almost 2 years agoLasted 28 days

Affected

Partner Services

Operational from 3:24 PM to 3:37 PM

Click Dimensions Marketing Automation

Operational from 3:24 PM to 3:37 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Update
    Update

    Update - Our team has been able to implement a fix and we are seeing improved performance.

    At this time we are not seeing delays in progression and will continue to monitor for a few days. We will provide a root cause in the coming days.

  • Update
    Update

    Update - For customers on our US Data center: a new Campaign Automation IP Address has been created, thus needs to be whitelisted on any relevant firewalls. The new IP address is 20.98.25.64/28 (20.98.25.64 / 255.255.255.240).

  • Monitoring
    Monitoring

    Monitoring - Our team is continuing to work with our Microsoft cloud services provider for a long term fix for this issue. We have a critical severity escalation with their App Service team at this time.

    You should not experience any data loss or participant failures due to this issue. If you are seeing participant delays of more than a few hours at each node, please alert the support team of this for additional investigation.
    Jun 01, 2023 - 19:31 UTC

  • Investigating
    Investigating

    Investigating - Currently our technology team has narrowed down the issue to our Microsoft Services. We have a critical severity escalation with their App Service team at this time and continue and hard at work to expedite the resolution of this issue.

    May 25, 2023 - 12:31 UTC
    Update - Our team continues to investigate this issue. We are seeing intermittent delays in the processing of Campaign Automations, primarily in our US data center.