Affected
Degraded performance from 4:03 PM to 6:05 PM
Degraded performance from 4:03 PM to 6:05 PM
Degraded performance from 4:03 PM to 6:05 PM
Degraded performance from 4:03 PM to 6:05 PM
Degraded performance from 4:03 PM to 6:05 PM
- ResolvedUTCResolvedUTCThis incident has been resolved.
- MonitoringUTCMonitoringUTC
Update from Microsoft:
We would like to provide an update regarding the service degradation experienced on 20 August 2026 between 12:07 UTC and 15:45 UTC.
During this period, your organization experienced intermittent service degradation, including increased latency and failures during platform operations. The impact was caused by an infrastructure issue affecting a dependent service, which resulted in reduced service capacity and degraded performance.
Microsoft Engineering teams investigated the issue and identified the affected infrastructure components. Mitigation measures, including service failover and capacity scale-out activities, were successfully implemented to restore service availability and performance. Service health validations have confirmed that the environment has recovered and is operating normally.
At this time, the service has been fully restored and is operating within expected performance parameters. Our teams continue to closely monitor the environment to ensure ongoing stability and reliability.
Additionally, Microsoft is conducting a detailed root cause analysis and reviewing further resiliency and automated recovery improvements to help minimize the likelihood and impact of similar incidents in the future.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding throughout this event.
- IdentifiedUTCIdentifiedUTC
Update from Microsoft:
Based on our initial analysis, the slowness and timeout behavior reported across the Dynamics 365 CRM environment is related to a known platform issue currently being investigated by Microsoft Engineering teams.
The impact has been observed primarily within the Canada region, where elevated gateway thread pool scheduling latency and intermittent 503 (Service Unavailable) errors have resulted in degraded service performance. This may affect multiple scenarios, including:
Approval operations
Test flow executions
Manual flow invocations
General web role latency
Power Automate related service operations
Microsoft Engineering teams have identified the underlying platform issue and have already rolled out mitigation measures to reduce the impact. Service performance has improved following the mitigation deployment; however, the incident remains under active investigation as engineering teams continue to monitor the service, validate the effectiveness of the mitigation, and work toward complete service restoration.
The issue has been appropriately escalated and is receiving active attention from the responsible engineering teams. Coordination is ongoing with relevant platform teams, including Core Services and Service Fabric engineering groups, to determine the underlying cause and implement any additional corrective actions as needed.
We understand the business impact of this issue and appreciate your patience and cooperation while our teams continue working toward full resolution. We will keep you informed of any significant updates as they become available.
- InvestigatingUTCInvestigatingUTC
There have been a few customer reports on overall CRM and portal performance. Microsoft has not updated their status page with any known current issue. We have opened a case with Microsoft and will continue to monitor their status page for any updates.

